Facing issues in installing Agent app

Hi, I am trying to install Agent app to my DAO following this link - How to use Aragon Agent · Aragon Developer Portal.

I need help with arapp.json file content.

what should be the configuration for polygon network?

currently, I have this configuration.

“aragon:polygon”: {
“apm”: {
“ipfs”: {
“gateway”: “https://ipfs.eth.aragon.network/ipfs
“registry”: “”,
“appName”: “foo.open.aragonpm.eth”,
“wsRPC”: “”,
“network”: “polygon”

What should be the registry address for polygon network?

what specifically are you trying to accomplish? many commands are available through https://evm-crispr.blossom.software/ and it’s both better maintained and safer in many ways since we should be able to test any of your commands on rinkeby or mumbai networks before jumping on a production net

HI, thank you so much for the quick response.

I tried EVMcrisper as well, I am able to install agent to dao deployed on rinkeby network. However, when I try to install agent for dao on polygon, it raises an error. Please check the error in the screenshot.

Also, I checked this thread regarding the issue. Commons Swarm Outcomes (3/3): A tool to mutate a DAO's DNA - #6 by sem - 🔥Swarms - 1Hive. But I could not follow the instructions.

Example (unwrap wxDAI):

looks like you may have a small issue in your code (agent:new-agent instead of agent:new

connect yourDAO token-manager voting
install agent:new-agent
grant voting agent:new-agent TRANSFER_ROLE voting
exec vault transfer @token(WXDAI) agent:new-agent 100e18
act agent:new-agent @token(WXDAI) withdraw(uint256) 100e18
exec agent:new-agent transfer XDAI vault 100e18

I got same error after using agent:new-agent instead of agent:new command.

Also, previous commands were working on rinkeby network DAO.